Les différences entre les versions 2.8 et 2.9

Les modules de la version EOLE 2.9 s'appuient sur la distribution GNU/Linux Ubuntu 22.04 LTS nommée également Jammy Jellyfish.

Ubuntu 22.04 LTS est disponible depuis le mois d'avril 2022. Portant le label LTS[1], cette version est soutenue et mise à jour pendant une durée de cinq ans, son support s'arrête donc en avril 2027. Le Pôle de Compétences Logiciels Libres prend en charge son support jusqu'à fin juin 2027.

Noyau Linux

Cette nouvelle version d'Ubuntu implique également un changement de version du noyau avec de nouvelles prises en charge matériel.

Les modules EOLE 2.9 utilisent par défaut le noyau le plus récent de la distribution Ubuntu, soit, à ce jour une version linux-image-generic 5.15.0.

OpenSSH

Le passage à la version 8.9 supprime notamment la prise en charge des mots de passe hachés en MD5[2].

Les algorithmes de signature Ed25519 et ssh-rsa/SHA-2 sont à privilégier.

Modules disponibles sur EOLE 2.9

#FIXME

Le module Horus ne sera pas porté en version 2.8.

Le module Amon est mis à disposition à partir de la version 2.8.1.

Le nouveau module Seth-Education est proposé à partir de la version 2.8.1.

Une nouvelle version du module AmonEcole est proposée à partir de la version 2.8.1.

Modules supportés par Zéphir 2.9

En version 2.9, un module Zéphir gère les modules EOLE de la version 2.6.0 jusqu'à sa propre version d'EOLE 2.9.

PostgreSQL 14

La version de PostgreSQL[3] disponible sur Ubuntu 22.04 est PostgreSQL 14.

OpenLDAP 2.5

La version d'OpenLDAP[4] disponible sur Ubuntu 22.04 est OpenLDAP 2.5.

Dans cette version, le support du backend obsolète BDB a été supprimé.

En version 2.9, c'est désormais le backend OpenLDAP MDB[5] qui est utilisé.

2.9.0

Moteur de conteneur Podman

En 2.9.0, EOLE intègre le moteur de conteneur[6] Podman[7] avec une première implémentation pour le service EoleSSO et une seconde pour l'IHM ERA.

Mode promiscuité sur les interfaces

De nouvelles variables permettent d'activer le mode promiscuous[8] interface par interface.

Dans le cas de l'installation d'un module Scribe ou AmonEcole dans Virtualbox, leur activation est nécessaire.